WordPressのアップグレード(2度目)

パソコンを組み立て、OS・ドライバ・ソフトをインストールして一応の
設定も済み、パソコンの方は順調に???使えるようになり(と思う)
先日ブログを書いた時、WordPress Ver2.9が出ているのでアップグレードして
くださいという情報を見たので、アップグレードしてみました。

(以前何か失敗して、ブログの記事をすべて飛ばした事があったのでドキドキ
しながらの作業です)

WordPress のアップグレード/詳細
http://wpdocs.sourceforge.jp/WordPress_のアップグレード/詳細

上記のページ手順を参考にしながら、バックアップ・旧ファイルの不要部分の
削除・新ファイルのアップロードとたぬきむらがやったにしては怖いほど順調に
進み、4ヶ月前にアップグレードした事があったので、その経験が役に立ち
な~んだ心配する事は無かった~と思って喜んでいたところ・・・

・・・やはりトラブルが~(たぬきむららしさが~)

手順 9: WordPress データベース・アップグレードプログラムを実行
実行してみると何かエラーが・・・
(エラーが出た時点でもうパニックになり詳しいエラー内容はよく覚えて
いませんが)

WordPress Ver2.9を使うには、MySQL 4.1.2 以上が必要
(上記参考ページをよく読むと、上の方にちゃんと書かれていました)

MySQL??? どこかでこの文字見たことはあるけど??何だったかな?
これをアップグレード?
どうすれば?
使用しているサーバーは対応している?
(レンタルサーバー屋さんのページにはMySQLに関しての質問は
お受けできませんというような事が書かれているしどうしよう)

個人的なブログなら、分けがわからないのでもう止めてしまうところですが
さすがに止めてしまうわけにもいかないし・・・
元のバージョンに戻すのはセキュリティ問題とかあるかもしれないし・・・

そういえばレンタルサーバー屋さんからMySQLとかの新しいバージョンが使える
ようになったという案内メールが数ヶ月前に送られて来ていたような。
それを思い出し、レンタルサーバー屋さんのサイトに行き、ヘルプをみたり
インターネットの検索を利用したりしながら何とかMySQLのバージョンアップも
出来て、これでまた皆さんに見てもらえる様に出来た!
とブログを開こうとするとまだ見れない(><

結局WordPressのファイルのデータベースサーバーアドレス?を新しい
アドレスに書き換えるのを忘れていて、書き換えてアップロードしたら
見れる状態に出来ました。

が、まだちょっとした問題がありました。

文字にリンクをつけようとしたところ、ポップアップ画面が真っ白で
何も表示されない!
JAVAやJavaScriptやAxtiveXを有効にしてみてもダメ。ブラウザを変えてもダメ。
HTML形式でリンクを追加すれば出来ない事は無いのであまり大きな問題では
無いのですが・・・

こちらの問題はセキュリティソフトの設定でした。パソコンを新しくして
セキュリティソフトをインストールしなおした後、設定をし忘れていました。

かれこれ6時間ほど格闘?の末、以前書いた記事を飛ばしてしまう事も無く
また皆さんに見て頂けるように出来ました。
ふ~う、良かった、あのまま見てもらえない状態だったら新年早々から
会社に行って謝らないといけない様になるところでした。

うっ、この記事を投稿しようとログインしてみたら、Ver2.9.1が(^^;

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です